To run with JRebel Agent,use:-agentpath:/Users/…/.jrebel/lib/libjrebel64.dylib

Forum on this website is being phased out. New threads or replies cannot be posted. Existing content remains available for now in read only mode. You can contact technical support at support@zeroturnaround.com.

ZeroTurnaround Homepage Forums JRebel Support To run with JRebel Agent,use:-agentpath:/Users/…/.jrebel/lib/libjrebel64.dylib

This topic contains 1 reply, has 1 voice, and was last updated by  syeremy 1 year, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #61631

    syeremy
    Member

    HEllo,

    I upgraded to jrebel 7.0, and after that i started getting that issue. even after adding the right configuration to the MAVEN_OPTS in my .bash_profile.

    export MAVEN_OPTS="-agentpath:/Users/syeremy/.jrebel/lib/libjrebel64.dylib $MAVEN_OPTS"

    This is the command is not working for me :
    mvn -P cargo.run -D repo.path=storage -D jrebel

    although this command works properly for me :

    mvn clean verify -D jrebel

    This is the complete log i am getting :

    [INFO] [talledLocalContainer] To run with JRebel Agent, use: -agentpath:/Users/syeremy/.jrebel/lib/libjrebel64.dylib
    [INFO] [talledLocalContainer] For more information, please read https://zeroturnaround.com/software/jrebel/jrebel7-agent-upgrade-cli/
    [INFO] [talledLocalContainer] 
    [INFO] [talledLocalContainer] JRebel Agent is building a bootclass cache to /Users/syeremy/dev/projects/.../target/tomcat8x/temp/rebelboot.jar
    [INFO] [talledLocalContainer] 
    [INFO] [talledLocalContainer] Check the instructions above to start using JRebel. The JVM will now exit.
    #61634

    syeremy
    Member

    Found the solution.

    We can specify that property in the POM :

        <profile>
          <id>default</id>
          <activation>
            <activeByDefault>true</activeByDefault>
            <property>
              <name>jrebel</name>
            </property>
          </activation>
          <properties>
            <javaagent>-agentpath:/Users/syeremy/.jrebel/lib/libjrebel64.dylib</javaagent>
          </properties>
        </profile>

    and because that is a configuration specific for my laptop, i needed to move it from my project POM to my %USER_HOME%/.m2/settings.xml configuration.

    Hope that can help to someone else

Viewing 2 posts - 1 through 2 (of 2 total)

The forum ‘JRebel Support’ is closed to new topics and replies.