RestEasy JaxRsActivator not automatically triggering new Service instantiation

ZeroTurnaround Homepage Forums JRebel Support RestEasy JaxRsActivator not automatically triggering new Service instantiation

This topic contains 3 replies, has 2 voices, and was last updated by  Vita Krainik 2 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #66479

    alfmateos
    Member

    When I create a new method for an existing REST webservice it works like a charm without recompiling nor restarting jboss. But when I create a new WebService from scratch it doesn’t: it needs to restart JBoss.

    I’m using JBoss EAP 6.3.0.GA (AS 7.4.0.Final-redhat-19) with Resteasy 3.0.6.Final. It looks that JaxRasActivator does not get reloaded when I recompile the newly created service:

    @ApplicationPath(“/api/v1”)
    public class JaxRsActivator extends Application {
    /* Intentionally left blank */
    }

    If we try to invoke our REST ws we get a 404 error, it can’t find the path of the new web service.

    How could we workaround this?

    Thanks a lot.

    #66486

    Vita Krainik
    Rebel Staff

    Hello, Alfonso!

    Can you enable trace logging and send a trace jrebel.log after reproducing the error to support@zeroturnaround.com? This would give us more context about the issue.

    Also, please specify if you have resource scanning enabled or if you are modifying getClasses() method to list a new resource.

    About sending logs and how to enable tracing:
    https://manuals.zeroturnaround.com/jrebel/misc/sendinglogs.html#sending-logs

    #66528

    alfmateos
    Member

    Hi Vita,

    I copy the message I sent you yesterday via email, I attached that log, I don’t know if I should have answered here and not via email so I copy it here again.

    I attach the log, around 2017-11-14 10:29 you will see the reloading of the new service, both the interface and the implementation, their names are JRebelPocService and JRebelPocServiceImpl.

    We use JEE, not Spring, just to give you more details.

    We are not using resource scanning enabled nor modifying getClasses. After reading your answer I tried this inside my web.xml:

    And I still get that javax.ws.rs.NotFoundException, you’ll see its effect in jrebel.log at 2017-11-14 11:28:47.964, about JrebelService3.

    I send you the full log and I keep waiting how to proceed, maybe I misunderstood you about resource scanning enabled.

    Thanks in advance.

    #66789

    Vita Krainik
    Rebel Staff

    The issue is fixed in Nighlty build, reloading new resources using RestEasy and JAX-RS will be added to JRebel 7.1.4 release.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.