Redeployment problems on Weblogic

ZeroTurnaround Homepage Forums JRebel Support Redeployment problems on Weblogic

This topic contains 1 reply, has 2 voices, and was last updated by  Valerie Avramenko 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #62012

    Aleksander
    Member

    We are having problems with redeployment on Weblogic 12.1.3 with JRebel enabled. When we rebuild our application and redeploy it on weblogic(outside of JRebel synchronisation) no changes are seen unless we restart weblogic server. Undeploying application and then deplyoing it again with new changes still requires weblogic restart for changes to be seen! Furthermore, there are nor warnings or errors emitted. This problem does not happen when we disable JRebel. If I remember correctly we started having those issues ever since JRebel 6.4.8.

    Weblogic: Weblogic 12.1.3 patchset 24904852
    JRebel: JRebel Agent 7.0.7-SNAPSHOT (201703171428)
    OS: OracleLinux on Docker container
    Java: 8u121
    Remote: yes

    Rebel opts:

    -agentpath:${REBEL_HOME}/lib/libjrebel64.so \
    -Drebel.remoting_plugin=true \
    -Drebel.remoting_port=${REBEL_PORT} \
    -Drebel.log=true \
    -Drebel.log.file=${USR_HOME}/logs/jrebel.log \
    -Drebel.disable_update=true \
    -Drebel.stats=false \
    -Drebel.usage_reporting=false \
    -Drebel.check_class_hash=true
    #62095

    Valerie Avramenko
    Rebel Staff

    Hello Aleksander!

    Thank you a lot for the environment description! Could you please also send your trace level jrebel.log file after trying to deploy your chnges to support@zeroturnaround.com with the link to this forum topic? To generate it just add -Drebel.log=trace to your VM arguments, restart your server and reproduce the issue (the file will be in your remote server .jrebel folder).

    We fixed few bugs with Weblogic 12.1.3 but seems something is still failing and this log file should give us full context.

    Kind regards,
    Valerie

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.