JRebel breaks on Build

Forum on this website is being phased out. New threads or replies cannot be posted. Existing content remains available for now in read only mode. You can contact technical support at support@zeroturnaround.com.

ZeroTurnaround Homepage Forums JRebel Support JRebel breaks on Build

This topic contains 3 replies, has 2 voices, and was last updated by  iqviastudio 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #67225

    iqviastudio
    Member

    After an uninstall of 7.1.8 – installed 7.1.7 but it looked for the 7.1.5 original install location. Previously I changed the folder to old version number and it worked. Now it’s looking for a directory within the folder that doesn’t exist.

    Error occurred during initialization of VM
    Could not find agent library C:\Users\Q799394\eclipse-Neon\plugins\org.zeroturnaround.eclipse.embedder_7.1.5.RELEASE\jrebel\lib\jrebel64.dll in absolute path, with error: Can’t find dependent libraries

    #67260

    Valerie Avramenko
    Rebel Staff

    Hello!

    We usually do not recommend playing around with folders’ names as manually it nearly impossible to track all the references. Have you tried uninstalling JRebel completely and then installing again from Eclipse Marketplace?

    Kind regards,
    Valerie

    #67266

    iqviastudio
    Member

    Yes – I uninstalled from Eclipse (Neon) and tried Eclipse Marketplace and even Install New Software – I get the same error now “‘Installing Software’ has encountered a problem. An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.

    session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
    Error reading signed content.
    Exception in opening zip file: C:\Users\Q799394\eclipse-Neon\plugins\org.zeroturnaround.eclipse_7.1.7.RELEASE.jar

    #67294

    iqviastudio
    Member

    Found solution to install – shut down Eclipse > Moved artifacts.xml from eclipse-neon folder > restart Eclipse and Install New Software (it installed this time) > shut down Eclipse and put artifacts.xml back. Started up Eclipse and all working again.

Viewing 4 posts - 1 through 4 (of 4 total)

The forum ‘JRebel Support’ is closed to new topics and replies.