Gradle Build failed – cant support Java 8

ZeroTurnaround Homepage Forums JRebel Support Gradle Build failed – cant support Java 8

This topic contains 1 reply, has 2 voices, and was last updated by  Hannes Metssalu 7 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #61784

    Hoe Lee
    Member

    JRebel for android failed to compile, java 8 should have below support in Gradle.
    compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_8
    targetCompatibility JavaVersion.VERSION_1_8
    }

    Error message as follow:

    
    1:14:25 PM Platform and Plugin Updates: The following components are ready to update: Android Support Repository, Google Repository, Google APIs Intel x86 Atom System Image, Android SDK Tools 25.2.5
    1:14:26 PM Gradle sync started
    1:14:55 PM Gradle sync completed
    1:14:56 PM Executing tasks: [:app:generateDebugSources, :app:mockableAndroidJar, :app:prepareDebugUnitTestDependencies, :app:generateDebugAndroidTestSources]
    1:15:19 PM Gradle build finished in 23s 615ms
    1:15:43 PM Cannot Run with JRebel for Android: Gradle build failed! Check the messages tab.
    

    Any solution?

    #61786

    Hannes Metssalu
    Rebel Staff

    Are you using Jack compiler for Java 8 – unfortunately it’s not yet supported. We do have it in our short term plans though so make sure to always follow our changelog.

    As a workaround please use Retrolambda for Java 8 features.

    If you don’t think that this is the issue and you are already using Retrolambda, please reproduce the issue and send us a submission through IDE with all the logs. Tools > JRebel for Android > Send feedback.

    All the best,
    Hannes Metssalu

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.